Webster’s Citrix Documentation Scripts and Microsoft PowerShell Version 4

Microsoft recently released their Windows Management Framework 4 which includes PowerShell 4.0.  I recently made sure all the current and future scripts worked with PowerShell Version 3.

The following were tested:

  • XenApp 6 on Windows Server 2008 R2 SP1, PowerShell V2, V3 and V4 – script versions 3 and the in development V4.
  • XenApp 6.5 on Windows Server 2008 R2 SP1, PowerShell V2, V3 and V4 – script versions 3.1 and the in development V4.
  • The PVS version 3 script was updated to support PVS 7.1 running on Server 2012 R2.  Server 2012 R2 includes PowerShell V4 so the PVS script has already been tested with PowerShell V4.

All the V4 scripts are being developed exclusively with PowerShell V4.

I have updated all the appropriate ReadMe files and the Where to Get Copies of the Various Documentation Scripts article.

Thanks

Webster

, ,

About Carl Webster

Webster is a Sr. Solutions Architect for Choice Solutions, LLC and specializes in Citrix, Active Directory and Technical Documentation. Webster has been working with Citrix products for many years starting with Multi-User OS/2 in 1990.

View all posts by Carl Webster

No comments yet.

Leave a Reply