Is Your iPad or iPhone Slow to Access Your XenApp Services Site?

I really like using my Apple iPad for accessing published applications on my Citrix XenApp servers hosted on Citrix XenServer 5.6.  I had four problems I thought were related to the Citrix Receiver for iPad.  From comments made by customers and from questions posed on Experts Exchange, I am not the only one experiencing these issues.

  1. The iPad will connect to the XenApp Services Site maybe 10% of the time.
  2. When attempting to connect to the XenApp Services Site, the process would take well over 10 minutes.
  3. When a connection is made, not all the application icons will be shown.
  4. Received a “Protocol Driver Error” until all XenApp 5 for Server 2003 servers were removed from both Citrix Secure Gateway and Web Interface.

Recently a colleague at work sent an e-mail saying they had finally resolved the slow iPad access issue for a customer.  I tried what he recommended and it worked perfectly for me.  The solution fixed all four issues.

When you install the XenServer 5.6 Para virtualization drivers, the network interface has four properties (Figure 1).

Figure 1

By default, all four properties are enabled.  The simple fix is to Disable all four properties.  No reboot is necessary.  This needs to be done for Windows Server 2003 and Server 2008 32-bit.  Windows Server 2008 R2 is not affected.  I have not tested this on Server 2003 or Server 2008 64-bit.

Once I made these changes to my XenApp 5 and Citrix Secure Gateway/Web Interface servers, my iPad connects 100% of the time in less than 2 seconds, all my application icons are shown (Figure 2) and no more protocol driver errors.

Figure 2

, , , ,

About Carl Webster

Webster is a Sr. Solutions Architect for Choice Solutions, LLC and specializes in Citrix, Active Directory and Technical Documentation. Webster has been working with Citrix products for many years starting with Multi-User OS/2 in 1990.

View all posts by Carl Webster

No comments yet.

Leave a Reply