Citrix NetScaler Documentation Script Version 3.0

May 24, 2016

Blog

Barry Schiffer and Iain Brighton are pleased to release Version 3.0 of the NetScaler documentation script.

#Version 3.0 24-may-2016

  • Uses Nitro API to connect to NetScaler instead of ns.conf
  • Microsoft Office 2016 support
  • NetScaler 11.0 support
  • Documents hardware revision
  • Documents NetScaler Edition
  • Documents SSL Certificates, including expiry date
  • Shows all policies, including default
  • Shows all routes, including default
  • Shows all monitors, including default

Because Barry’s Version 3 of the script uses the Nitro API, Barry asked me to only release a Signed version of the script. Please only use the script when the signed script is validated just so you know the script has not been altered.

As the documentation script only reads information there is no risk in using the script. However we advise to use a read only account for the script, according to security best practices it’s common sense to use least privileges for service accounts.

You can always find the most current script by going to http://carlwebster.com/where-to-get-copies-of-the-documentation-scripts/

Thanks

Webster, Barry and Iain

About Carl Webster

Webster is a Sr. Solutions Architect for Choice Solutions, LLC and specializes in Citrix, Active Directory and Technical Documentation. Webster has been working with Citrix products for many years starting with Multi-User OS/2 in 1990.

View all posts by Carl Webster

6 Responses to “Citrix NetScaler Documentation Script Version 3.0”

  1. David Says:

    Hi. I tried to get the script working & have download .NET & JAVA versions of NITRO API but how to I install them into my Win10 (or Win7) OS to get the Netscaler Documentation script to detect the settings? The sciptted worked but didn’t detect anything….
    Thanks
    Dave

    Reply

    • Carl Webster Says:

      From Barry:

      “You don’t need all this stuff to get it working. The only thing he needs is Powershell.”

      Webster

      Reply

  2. Anas Says:

    Hello Carl,

    I am not able to use the NetScaler v3 script. Is there any prerequisite? Do I need to install somehting before I can use this? I ran the command “.\NetScaler_Script_v3_Signed.ps1 netscaler_ip” but it gave lots of errors.

    Thanks

    Reply

  3. Danny Gullcik Says:

    Hi, I have started using the Netscaler script and like what I am seeing so far. One thing I noticed is that for any given Service Group the listed monitor is incorrect. As a matter of fact, it seems the same Monitor is used for every service group. Could this be looked at and corrected? Thanks a bunch! Regards, Danny

    Reply

Leave a Reply